mooncakes error:could not find the latest version of PerfectPan/base64

#ls

    Mode                 LastWriteTime         Length Name
    ----                 -------------         ------ ----
    d-----         6/12/2024   9:05 PM                .mooncakes
    d-----         6/12/2024   8:49 PM                lib
    d-----         6/12/2024   8:49 PM                main
    d-----         6/12/2024   9:05 PM                target
    -a----         6/12/2024   8:49 PM             20 .gitignore
    -a----         6/12/2024   8:49 PM            163 moon.mod.json
    -a----         6/12/2024   8:49 PM             16 README.md

moon add PerfectPan/base64

    error: could not find the latest version of PerfectPan/base64

Please run moon update first to update the index

moon update
moon add PerfectPan/base64

thanks